Stripe Connect Express

Incident Report for WAVjunkie

Postmortem

Date: 5 April 2026

Duration: Approximately 5 hours from first report to fix resolution, with incident closed following multiple tests and no further issues reported for a minimum of 1 hour following the fix

Severity: Minor - no financial impact, no data loss, no payout disruption

Summary

Shortly after 2pm CEST, a user reported that their Stripe Connect Express account had been created with Spain set as the account country. Investigation confirmed that the country parameter was not being passed from the artist's account during Stripe Connect onboarding, causing Stripe to default all new Connect Express accounts to Spain regardless of the artist's actual location.

The issue was identified, investigated, and resolved on the same day. A country selector was added to profile settings and a Reset & Reconnect option was introduced to the payouts modal, allowing affected artists to delete their country-locked Stripe Connect profile and create a new one using their correct country.

Impact

Artists who completed Stripe Connect onboarding during the affected window had their Connect Express account created with Spain as the default country. As Stripe Connect requires completion before music uploads are permitted, affected artists were temporarily unable to upload music until they used the Reset & Reconnect flow to recreate their payout account.

It is important to note that this issue had no bearing on the ability to receive payouts. Stripe Connect does not require the account country to match the country of the connected bank account. No earnings were at risk and no financial data was affected.

Timeline

Time Event
14:01 CEST First user report received. Stripe Connect account showing Spain as account country
14:03 CEST - Shortly after report Investigation begins. Stripe Connect integration reviewed
14:34 CEST Root cause identified. Country parameter not being passed from artist account during Connect onboarding
16:31 CEST Fix deployed. Country selector added to profile settings; Reset & Reconnect button added to payouts modal
Resolution - tested with multiple accounts All artists able to recreate Stripe Connect account using correct country

Root Cause

The Stripe Connect Express onboarding flow was not receiving the country parameter from the artist's account at the point of initialising the Connect session. With no country passed, Stripe defaulted the Express account to Spain - the country associated with the first-created platform account. This meant every artist who completed Stripe Connect onboarding during this window had their Express account created under the Spain jurisdiction regardless of their actual location.

Resolution

Two changes were deployed to resolve the issue:

Country selector in profile settings

Artists can now set their country directly within their WAVjunkie profile settings. This value is passed to Stripe Connect during onboarding to ensure the Express account is created under the correct country.

Reset & Reconnect in payouts modal

A Reset & Reconnect button was added to the payouts section. This allows any artist whose Stripe Connect account was created with an incorrect country to delete that account and initiate a fresh onboarding using the correct country from their profile settings.

What Was Not Affected

  • No artist earnings were at risk at any point
  • No financial data was compromised or incorrectly stored
  • Payout functionality is unaffected - Stripe Connect does not require account country to match bank account country
  • No listener purchases or downloads were disrupted
  • No personal data was exposed

Preventative Actions

  • Country parameter is now explicitly passed at every point of Stripe Connect initialisation
  • The Reset & Reconnect flow remains available in the payouts modal as a permanent recovery option for any future onboarding issues
  • Stripe Connect onboarding will be included in pre-launch integration testing for all future platform updates that touch the payments flow

We want to thank the artist who identified and reported this issue. Their prompt report allowed us to investigate and resolve it quickly. This is exactly the kind of community that makes WAVjunkie better.

Posted Apr 05, 2026 - 21:59 CEST

Resolved

After monitoring and testing, this incident appears to have been resolved. Thank you for your patience.
Posted Apr 05, 2026 - 18:58 CEST

Monitoring

A fix has been implemented and we are monitoring the results.

Stripe now uses the artist’s profile country (this can now be set manually in your profile settings), missing-country onboarding is blocked with a clear message, and artists can click Reset & Reconnect on the payouts modal if Stripe locked the wrong country.
Posted Apr 05, 2026 - 16:30 CEST

Update

We are continuing to work on a fix for this issue.
Posted Apr 05, 2026 - 16:09 CEST

Update

We are continuing to work on a fix for this external issue.

No in-house components of WAVjunkie are affected.

If you are based in Spain, you can setup payouts as normal, as this is what Stripe Connect Express is currently defaulting to.

Thank you for your patience and please accept our apologies for any inconvenience.
Posted Apr 05, 2026 - 15:24 CEST

Identified

The root cause has been identified and a fix is being prepared.

The cause is Stripe Connect not passing the correct artist account country parameters and defaulting to the country of the first created account, in this case Spain. If you are based in Spain, you can proceed as normal.

A fix is being prepared. Thank you for the patience during this period.
Posted Apr 05, 2026 - 14:34 CEST

Investigating

We are currently investigating an issue where Stripe is defaulting artist countries to Spain.
Posted Apr 05, 2026 - 14:01 CEST
This incident affected: WAVjunkie Website.